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This supplement lays out the full data used in the analysis and provides detailed instructions and code for 
recreating the analyses and figures using free and open-source software.  

Three appendices are included here: 

Appendix A. Annotated R code for Analysis and Visualization 

Appendix B. Creating a Choropleth Map of HDI in Ohio Counties in QGIS (Quantum GIS 2.18.3) 

Appendix C. HDI Data for Ohio Counties 
 
 

mailto:r-kauffman.2@onu.edu


ojph.org Ohio Public Health Association 
2 

Supplemental Material 

Appendix A. Annotated R code for Analysis and Visualization 

 

 

################################################################################### 
# R Program for Epi Section Collaborative Paper 1                                 # 
# Ross M. Kauffman                                                                # 
# June, 2019                                                                      # 
################################################################################### 
 
# This code is intended to be shared and modified 
 
################################################################################### 
# NOTE: Paths will need to be edited to match the save location of your files     # 
################################################################################### 
 
#Reading in dataset 
HDIPre <- read.csv(file="C:/HDI and Opioid Prescription/HDI-Prescriptions.csv", header=TRUE, 

sep=",") 
 
#Changing font to Times New Roman 
par(family="serif") 
 
#Chart using Solarized color palette by Ethan Schoonover 
 
plot(HDIPre$AmerHDI, HDIPre$Opioids, pch=16, col="#cb4b16", 
 xlim=c(3,8),ylim=c(0,100),  
 xlab="American HDI", ylab="Drug prescriptions per capita") 
text(8, 45, expression("Opioids"), pos=2, col="#cb4b16") 
text(8, 42.5, expression(r^2== 0.22), pos=2, col="#cb4b16") 
points(HDIPre$AmerHDI, HDIPre$Benzodiazepines, pch=18, col="#268bd2") 
text(8, 20, expression("Benzodiazepines"), pos=2, col="#268bd2") 
text(8, 17.5, expression(r^2== 0.18), pos=2, col="#268bd2") 
points(HDIPre$AmerHDI, HDIPre$Stimulants, pch=17, col="#d33682") 
text(8, 10, expression("Stimulants"), pos=2, col="#d33682") 
text(8, 7.3, expression(r^2== 0.24), pos=2, col="#d33682") 
points(HDIPre$AmerHDI, HDIPre$Sedatives, pch=15, col="#859900") 
text(8, 3, expression("Sedatives"), pos=2, col="#859900") 
text(8, 0.3, expression(r^2== 0.01), pos=2, col="#859900") 
clip(3.32,7.55,0,100) 
abline(lm(HDIPre$Opioids~HDIPre$AmerHDI), lty=2, lwd=2, col="#cb4b16") 
abline(lm(HDIPre$Benzodiazepines~HDIPre$AmerHDI), lty=2, lwd=2, col="#268bd2") 
abline(lm(HDIPre$Stimulants~HDIPre$AmerHDI), lty=2, lwd=2, col="#d33682") 
abline(lm(HDIPre$Sedatives~HDIPre$AmerHDI), lty=2, lwd=2, col="#859900") 
 
#Saving output into a high quality PNG image 
dev.set(2) 
dev.print(png, file="C:/HDI and Opioid Prescription/Figure3.png", width=1950, height=2400, 

res=300) 
 
#Testing correlations 
cor.test(HDIPre$AmerHDI, HDIPre$Opioids) 
cor.test(HDIPre$AmerHDI, HDIPre$Benzodiazepines) 
cor.test(HDIPre$AmerHDI, HDIPre$Stimulants) 
cor.test(HDIPre$AmerHDI, HDIPre$Sedatives) 
cor.test(HDIPre$AmerHDI, HDIPre$Age) 
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Appendix B. Creating a Choropleth Map of HDI in Ohio Counties in QGIS (Quantum GIS 2.18.3) 

 

Quantum GIS is a free and open-source geographic information system available for download at https://

www.qgis.org/en/site/. 

1. Open QGIS. 

2. Create a new project (Project > New, or Ctrl+N). 

3. Create the base map. 

 Download the shapefile of Ohio Counties from the Ohio Department of Transportation’s Transpor-

tation Information Mapping System (TIMS): https://gis.dot.state.oh.us/tims/Data/Download 

(Boundaries > County > Export Data > To Shapefile). 

 Unzip the resulting archive to a known location. 

 Open the Data Source Manager in QGIS (Layer > Add Layer > Add Vector Layer). 

 Open the shapefile. 

█ Ensure the source type is set to “File.” 

█ Locate the shapefile folder by clicking the “…” button to the right of the “Vector Dataset

(s)” field. 

█ Double click the “.shp” file (“ODOT_County_Boundaries.shp”). 

█ Click the “Add” button to add the layer to your map. 

█ Click the “Close” button to close the Data Source Manager window. 

4. Select an appropriate coordinate reference system to minimize distortion. 

 Open the Project Properties window (Project > Properties…, or Ctrl+Shift+P). 

 Select the “CRS” tab. 

 Filter the CRS results by “Ohio” and select Authority ID EPSG:102722, the projection labelled 

“NAD_1983_StatePlane_Ohio_North_FIPS_3401_Feet” by clicking on the name. 

 Click the “Apply” button, then click “OK” to close the Project Properties window. 

5. Import the HDI data. 

 Create an “HDI.csv” file containing the needed data (at least one column labelled “FIPS” that con-

tains the county FIPS code and one column that contains the American HDI data labelled “HDI”). 

This can be done using spreadsheet software like Calc, Excel, or Sheets. 

 Open the Data Source Manager in QGIS (Layer > Add Layer > Add Delimited Text Layer). 

 Locate your “.csv” file by by clicking the “…” button to the right of the “File Name” field and nav-

igating to the appropriate location. 

 Double click on the “.csv” file to open it. 

 Under “Geometry definition” select the “No geometry (attribute only table)” option. 

 Click the “Add” button to add the layer to your map. 

 Click the “Close” button to close the Data Source Manager window. 

6. Link the data layer to your base map. 

 Double click your “ODOT_County_Boundaries” layer on the layers toolbar to select the layer and 

open the Layer Properties window. 

 Select the “Joins” tab. 

https://www.qgis.org/en/site/
https://www.qgis.org/en/site/
https://gis.dot.state.oh.us/tims/Data/Download
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 Click the green plus button to bring up the “Add Vector Join” window. 

 Make sure “Join layer” is set to “HDI.” 

 Set the “Join field” to “FIPS.” 

 Set the “Target field” to “FIPS_COUNT.” 

 Click “OK” to return to the Layer Properties window. 

7. Setup your symbology. 

 In the Layer Properties window, click the “Symbology” tab. 

 From the top dropdown box, change the selection from “Single symbol” to “Graduated.” 

 In the “Column” dropdown box, select the “HDI_HDI” column. 

 You may modify the “Color ramp” if desired to change the coloring of your map. 

 Set the mode to “Equal Interval.” 

 Up the “Classes” to 88. 

 Click the “Classify” button. 

 Click the “Apply” button, then click “OK” to return to close the layer properties window and return 

to your map.  

Your map is now complete. You can export your final product through the Project menu (Project > Import/
Export > Export Map to Image).  

Layers toolbar 
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Appendix C. HDI Data for Ohio Counties. 

County FIPS AmerHDI Health Education Income Opioids Benzos Stimulants Sedatives MedAge 

Adams 39001 3.61 3.81 4.00 3.01 95.9 38.3 7.3 4.9 42.1 

Allen 39003 4.72 4.98 5.96 3.24 48.4 17.7 6.9 4.6 38.2 

Ashland 39005 4.79 5.33 5.65 3.40 38.9 14.1 7.3 3.7 40.0 

Ashtabula 39007 4.26 4.43 4.84 3.50 53.1 19.7 7.9 5.0 42.2 

Athens 39009 3.40 4.54 7.64 -1.97 66.5 26.4 10.3 4.0 28.2 

Auglaize 39011 5.27 5.48 5.56 4.77 52.3 23.4 8.6 5.1 41.2 

Belmont 39013 4.45 4.81 5.31 3.24 57.5 21.5 5.0 6.2 44.1 

Brown 39015 4.20 4.15 4.29 4.16 73.1 21.1 7.6 4.7 41.1 

Butler 39017 5.32 4.95 6.37 4.65 62.6 32.4 13.7 6.4 36.5 

Carroll 39019 4.51 5.12 4.68 3.75 42.4 18.6 6.1 3.6 44.7 

Champaign 39021 4.83 4.75 5.39 4.35 66.2 21.3 9.4 4.3 41.6 

Clark 39023 4.46 4.31 5.51 3.56 76.3 27.4 10.0 5.9 41.2 

Clermont 39025 5.40 5.08 6.02 5.09 62.7 24.9 15.3 6.4 39.7 

Clinton 39027 4.58 4.50 5.23 4.01 75.4 30.5 10.1 6.2 39.4 

Columbiana 39029 4.38 4.85 4.93 3.37 59.9 30.1 9.0 6.0 43.4 

Coshocton 39031 4.22 4.79 4.45 3.43 57.2 22.6 4.4 3.5 41.2 

Crawford 39033 4.26 4.67 4.71 3.40 66 20.2 10.1 4.9 42.9 

Cuyahoga 39035 5.51 4.95 6.99 4.59 40.7 14.9 8.6 4.1 40.4 

Darke 39037 4.82 5.29 5.21 3.97 41.7 14.2 5.0 3.1 42.0 

Defiance 39039 4.94 5.28 5.55 3.99 44.2 18.7 6.1 4.5 39.9 

Delaware 39041 7.55 6.43 8.69 7.54 38.8 13.9 14.3 5.4 38.0 

Erie 39043 4.96 4.98 5.98 3.92 63.9 23.3 9.8 7 44.5 

Fairfield 39045 5.57 5.40 6.41 4.91 57.5 20.1 9.3 4.5 39.3 

Fayette 39047 4.32 3.89 4.93 4.15 63.2 21.3 7.5 4.5 41.3 

Franklin 39049 5.75 4.83 7.60 4.80 52.7 15.5 10.9 4.5 33.9 

Fulton 39051 5.16 5.42 5.57 4.49 56.3 23.9 13.1 5.1 40.0 

Gallia 39053 4.10 3.98 4.84 3.47 74.2 30 8.6 4.5 40.5 

Geauga 39055 6.25 6.52 6.41 5.84 35.3 14.2 9.5 5 44.2 

Greene 39057 6.19 5.66 8.22 4.71 43.6 17 6.6 3.8 38.0 

Guernsey 39059 4.26 4.50 4.76 3.50 74.8 48.8 6.0 5.2 42.3 

Hamilton 39061 5.52 4.68 7.21 4.67 49.1 20.7 13.1 5.5 37.0 

Hancock 39063 5.59 5.61 6.67 4.49 38.1 17 6.7 5.0 38.9 

Hardin 39065 3.98 4.54 5.01 2.40 55.6 22.2 6.6 3.9 35.8 

Harrison 39067 4.16 4.31 4.14 4.01 69 22.9 6.5 6.1 46.2 

Henry 39069 5.31 5.61 5.56 4.76 47.1 21.3 9.1 4.1 41.4 

Highland 39071 4.12 4.22 4.78 3.38 72.3 25.1 7.5 4.9 40.2 

Hocking 39073 4.45 4.46 5.38 3.51 88.2 30.2 9.2 6.1 42.7 

Holmes 39075 3.32 5.57 1.11 3.27 18.6 12.5 3.0 2.5 30.6 

Huron 39077 4.47 4.86 4.81 3.75 73.5 22.7 10.6 6.6 39.4 

Jackson 39079 4.30 3.58 5.24 4.08 98.6 40.6 7.5 5.6 40.3 

Jefferson 39081 4.33 4.08 5.50 3.42 79.2 35.2 6.4 7.0 44.5 

Knox 39083 4.59 5.09 5.45 3.25 54.6 24 10.1 5.0 39.0 

Lake 39085 5.85 5.53 6.65 5.37 50.5 18.9 9.2 5.7 43.3 

Lawrence 39087 4.28 3.86 5.16 3.83 57.8 30.3 9.7 5.5 41.4 

Licking 39089 5.29 5.03 6.33 4.50 53.8 16.9 10.0 4.0 39.8 

Logan 39091 4.69 4.71 4.86 4.50 67.1 18.5 9.0 4.8 41.2 

Lorain 39093 5.35 5.25 6.38 4.43 49.9 21.4 10.8 4.7 41.2 

Lucas 39095 4.91 4.61 6.33 3.78 61.6 22 13.1 5.1 37.9 
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Madison 39097 5.06 4.83 5.70 4.64 76.6 25.2 9.9 5.2 40.2 

Mahoning 39099 4.76 4.68 6.26 3.33 64.7 29.9 10.2 5.6 43.4 

Marion 39101 4.47 4.62 5.06 3.73 77.9 26.5 10.3 3.8 40.5 

Medina 39103 6.11 5.94 6.88 5.51 42.6 17.6 10.4 5.0 41.8 

Meigs 39105 4.10 4.13 4.71 3.46 64.4 23.8 7.6 3.6 42.8 

Mercer 39107 5.15 5.55 5.27 4.63 36.0 19.3 4.8 3.8 40.0 

Miami 39109 5.34 5.35 6.06 4.60 54.4 25.5 9.4 4.7 41.4 

Monroe 39111 4.02 4.85 4.66 2.55 43.8 19.3 4.0 4.6 46.3 

Montgomery 39113 5.13 4.55 6.87 3.98 63.5 28.6 8.4 5.7 39.4 

Morgan 39115 4.00 4.86 4.00 3.15 62.1 26.8 5.9 3.1 43.8 

Morrow 39117 4.77 5.10 4.97 4.25 58.1 16.3 7.5 3.2 41.5 

Muskingum 39119 4.48 4.60 5.22 3.61 77.6 47.9 8.4 5.8 40.2 

Noble 39121 3.84 6.27 4.68 0.56 39.6 31.5 3.7 3.7 47.9 

Ottawa 39123 5.32 5.56 5.86 4.53 59.8 26.2 9.2 6.2 47.8 

Paulding 39125 4.79 5.15 5.11 4.10 48.1 18.5 5.0 4.4 41.3 

Perry 39127 4.19 4.43 4.52 3.62 91.9 41.8 8.0 5.3 39.8 

Pickaway 39129 4.85 4.79 5.33 4.41 77.2 22.5 8.8 4.7 39.3 

Pike 39131 3.96 3.65 4.24 4.01 89.1 35.8 6.5 5.9 40.8 

Portage 39133 5.03 5.37 6.42 3.30 51.8 17.6 9.0 5.5 37.7 

Preble 39135 4.75 4.75 5.35 4.16 61.4 25.6 7.7 4.9 42.2 

Putnam 39137 5.58 5.85 6.10 4.77 35.8 15.0 4.9 4.2 39.4 

Richland 39139 4.53 4.92 5.36 3.31 50.0 15.4 7.2 5.3 41.2 

Ross 39141 4.63 4.11 5.39 4.40 86.9 44.3 9.0 6.1 40.4 

Sandusky 39143 4.94 5.03 5.42 4.37 46.8 17.5 6.8 4.1 41.5 

Scioto 39145 4.21 3.65 5.24 3.73 87.4 37.1 6.9 6.1 39.7 

Seneca 39147 4.72 5.06 5.53 3.58 54.4 22.6 7.6 5.7 39.4 

Shelby 39149 5.17 5.30 5.41 4.80 43.6 22.9 5.5 3.2 39.5 

Stark 39151 5.15 5.22 6.29 3.94 59.3 33.7 11.7 6.7 41.7 

Summit 39153 5.56 5.01 6.99 4.68 54.1 18.9 9.0 5.0 40.8 

Trumbull 39155 4.58 4.74 5.19 3.8 78.3 27.0 8.1 5.4 43.8 

Tuscarawas 39157 4.72 5.36 5.01 3.79 57.7 29.4 7.0 6.1 40.9 

Union 39159 5.95 5.45 6.58 5.82 49.6 15.3 11.4 4.2 38.2 

Van Wert 39161 5.10 5.34 5.59 4.36 40.9 15.9 5.3 3.3 41.4 

Vinton 39163 3.81 3.86 4.01 3.57 89.9 30.3 6.1 3.9 41.0 

Warren 39165 6.60 5.67 7.51 6.61 45.7 22.0 11.8 5.8 39.1 

Washington 39167 4.62 4.85 5.27 3.76 70.7 37.4 9.9 7.0 43.6 

Wayne 39169 4.83 5.35 5.27 3.86 47.8 20 9.4 5.1 38.8 

Williams 39171 4.85 5.38 5.30 3.86 38.1 15.0 6.7 3.4 41.6 

Wood 39173 5.45 5.55 7.23 3.56 44.3 18.7 11.5 4.9 34.7 

Wyandot 39175 5.11 5.28 5.34 4.71 44.5 20.1 8.3 3.8 41.7 


